I prefer descriptive variable and function names - like comments, they help
to make code so much easier to read.
One thing I wonder though... why do people prefer 'some_function_name()'
over 'SomeFunctionName()'? I personally don't like the underscore character
- it's an odd character to type when you're trying to get the name typed in,
and the shifted character, I find, is easier to input.
Cheers!
Jon
> -----Original Message-----
> From: Steve Underwood [mailto:steveu@coppice.org]
Some people still seem to be living in the age of K&R C, with 6 or 7
character variable names that demand some explanation. Maybe some day
they will awake to the expressive power of long (and well chosen) names.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Tue Jan 23 2001 - 21:00:27 EST