On Mon, Jun 10, 2002 at 07:22:26PM +0200, Oliver Neukum wrote:
>
> > > So is the consensus now that in general drivers should make sure any
> > > buffers passed to pci_map/unmap are aligned to SMP_CACHE_BYTES (and a
> > > multiple of SMP_CACHE_BYTES in size)? In other words if a driver uses
> > > an unaligned buffer it should be fixed unless we can prove (and
> > > document in a comment :) that it won't cause problems on an arch
> > > without cache coherency and with a writeback cache.
> >
> > And how about we don't call it SMP_CACHE_BYTES too? The processors
> > where this matters certainly aren't doing SMP...
>
> Definitely we should call it something different so we can limit it to
> architectures that need it.
No. We should just make it come out to a nop for arches that don't need
it. Otherwise we'll end up with ugly things like:
#ifdef CONFIG_NOT_CACHE_COHERENT
...
#else
...
#endif
All over things like USB...
-- Tom Rini (TR1265) http://gate.crashing.org/~trini/ - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Sat Jun 15 2002 - 22:00:18 EST