On Tue, Nov 19, 2002 at 08:04:33PM -0800, Davide Libenzi wrote:
> On Wed, 20 Nov 2002, Jamie Lokier wrote:
> > The `fd' field, on the other hand, is not guaranteed to correspond
> > with the correct file descriptor number. So.... perhaps the structure
> > should contain an `obj' field and _no_ `fd' field?
> > ...
> It's OK. I agree. We can remove the fd from inside the structure and have :
> struct epoll_event {
> unsigned short events;
> unsigned short revents;
> __uint64_t obj;
> };
Forget any argument I had against removing 'fd'. This sounds good.
Perhaps 'obj' should be named 'userdata'?
struct epoll_event {
unsigned short events;
unsigned short revents;
__uint64_t userdata;
};
mark
-- mark@mielke.cc/markm@ncf.ca/markm@nortelnetworks.com __________________________ . . _ ._ . . .__ . . ._. .__ . . . .__ | Neighbourhood Coder |\/| |_| |_| |/ |_ |\/| | |_ | |/ |_ | | | | | | \ | \ |__ . | | .|. |__ |__ | \ |__ | Ottawa, Ontario, CanadaOne ring to rule them all, one ring to find them, one ring to bring them all and in the darkness bind them...
- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Sat Nov 23 2002 - 22:00:31 EST