Re: Large-FAT32-Filesystem Bug

From: Torsten Scheck
Date: Fri Dec 05 2003 - 12:56:19 EST

Erik Andersen wrote:
On Fri Dec 05, 2003 at 10:52:31AM +0100, Torsten Scheck wrote:
I found a critical FAT32 bug when I tried to store data onto an
internal IDE 160 GB and onto an external USB2/FW-250 GB hard

Does this help?


[... int=>loff_t ino,inum-patch ...]

Hi Erik:

I applied your patch to 2.4.23 and it solved the problem. No more lost clusters. All data stays where it belongs.

I'll test it for a few days and get back to you later.

Thank you very much.


For those who play with vfat filesystems now:

I noticed that fsck.vfat just pretends to repair a _mounted_ vfat filesystem. You have to unmount it, so it is actually repaired. An error message would be appropriate here. I'll contact the dosfsck maintainer, but I thought telling you might avoid confusion.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at