Re: [ACPI] [PATCH] Updated patches for PCI IRQ resource deallocationsupport [2/3]
From: Zwane Mwaikambo
Date: Sat Sep 25 2004 - 06:20:00 EST
Kenji Kaneshige wrote:
> - Changed acpi_pci_irq_disable() to leave 'dev->irq' as it
> is. Clearing 'dev->irq' by some magic constant
> (e.g. PCI_UNDEFINED_IRQ) is TBD.
This may not be safe with CONFIG_PCI_MSI, you may want to verify against
that if you already haven't.
> +acpi_unregister_gsi (unsigned int irq)
> +{
> +}
> +EXPORT_SYMBOL(acpi_unregister_gsi);
Why not just make these static inlines in header files? Since you're on
this, how about making irq_desc and friends dynamic too?
Thanks,
Zwane
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/