Re: [PATCH] mm counter operations through macros

From: Nikita Danilov
Date: Sat Mar 12 2005 - 09:00:06 EST

Christoph Lameter writes:
> On Fri, 11 Mar 2005, Dave Jones wrote:
> > Splitting this last one into inc_mm_counter() and dec_mm_counter()
> > means you can kill off the last argument, and get some of the
> > readability back. As it stands, I think this patch adds a bunch
> > of obfuscation for no clear benefit.
> Ok.
> -----------------------------------------------------------------
> This patch extracts all the operations on counters protected by the
> page table lock (currently rss and anon_rss) into definitions in
> include/linux/sched.h. All rss operations are performed through
> the following macros:
> get_mm_counter(mm, member) -> Obtain the value of a counter
> set_mm_counter(mm, member, value) -> Set the value of a counter
> update_mm_counter(mm, member, value) -> Add to a counter

A nitpick, but wouldn't be it clearer to call it add_mm_counter()? As an
additional bonus this matches atomic_{inc,dec,add}() and makes macro
names more uniform.

> inc_mm_counter(mm, member) -> Increment a counter
> dec_mm_counter(mm, member) -> Decrement a counter

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at