Re: [PATCH] swsusp: misc cleanups [4/4]
From: Pavel Machek
Date: Sun Apr 24 2005 - 15:23:19 EST
> > > The following patch makes some comments and printk()s in swsusp.c up to date.
> > > In particular it adds the string "swsusp" before every message that is printed by
> > > the code in swsusp.c.
> > I don't like this one. Adding swsusp everywhere just clutters the
> > screen, most of it should be clear from context.
> Right. Still, I'd like to drop function names from debug messages
> and replace "suspend" with "swsusp" in some messages. I'll send another
> patch for it after 2.6.12 (please let me know if you don't think it's a good
> idea ;-)).
Well, I'll not say "no" just now ;-). I thought 'suspend' is nicer for
non-technical users, not being acronym.
> For now, please drop the patch altogether.
> > > @@ -1226,9 +1222,6 @@ static int check_sig(void)
> > >
> > > /**
> > > * data_read - Read image pages from swap.
> > > - *
> > > - * You do not need to check for overlaps, check_pagedir()
> > > - * already did that.
> > > */
> > >
> > > static int data_read(struct pbe *pblist)
> > Why is this comment no longer valid?
> It's just confusing. Initially, I didn't intend to change it, but then I read it
> and thought "What overlaps?". In data_read() there's nothing that could
> overlap with anything else ...
Well, if there were no checking in check_pagedir, we could end up in
situation where some page's address == some other page's original
address. That would be really bad. This comment says it can not happen
because care was taken in check_pagedir(). Perhaps it needs to be
Boycott Kodak -- for their patent abuse against Java.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/