Re: PROBLEM: Tyan s2822 and SATA slowness / erratic speeds kernel 2.6

From: Jones Joneser
Date: Wed Nov 16 2005 - 13:20:55 EST

We experience the same issue when using an LSI SATA controller and the Tyan motherboard. In addition we did try vanilla and experienced the same slowdown issues.


<BLOCKQUOTE style='PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #A0C6E5 2px solid; MARGIN-RIGHT: 0px'><font style='FONT-SIZE:11px;FONT-FAMILY:tahoma,sans-serif'><hr color=#A0C6E5 size=1>
From: <i>Tejun Heo &lt;htejun@xxxxxxxxx&gt;</i><br>To: <i>Jones Joneser &lt;joneserstein@xxxxxxxxxxx&gt;</i><br>CC: <i>linux-ide@xxxxxxxxxxxxxxx, linux-scsi@xxxxxxxxxxxxxxx,linux-kernel@xxxxxxxxxxxxxxx</i><br>Subject: <i>Re: PROBLEM: Tyan s2822 and SATA slowness / erratic speeds kernel 2.6</i><br>Date: <i>Wed, 16 Nov 2005 13:57:02 +0900</i><br>MIME-Version: <i>1.0</i><br>Received: <i>from ([]) by with Microsoft SMTPSVC(6.0.3790.211); Tue, 15 Nov 2005 21:00:16 -0800</i><br>Received: <i>(majordomo@xxxxxxxxxxxxxxx) by via listexpandid S932296AbVKPE5M (ORCPT &lt;rfc822;joneserstein@xxxxxxxxxxx&gt;);Tue, 15 Nov 2005 23:57:12 -0500</i><br>Received: <i>(majordomo@xxxxxxxxxxxxxxx) by id S932580AbVKPE5M(ORCPT &lt;rfc822;linux-scsi-outgoing&gt;);Tue, 15 Nov 2005 23:57:12 -0500</i><br>Received: <i>from ([]:62641 &quot;EHLO;)by with ESMTP id S932579AbVKPE5L (ORCPT&lt;rfc822;linux-scsi@xxxxxxxxxxxxxxx&gt;);Tue, 15 Nov 2005 23:57:11 -0500</i><br>Received: <i>by with SMTP id 13so1684427nzn for &lt;linux-scsi@xxxxxxxxxxxxxxx&gt;; Tue, 15 Nov 2005 20:57:10 -0800 (PST)</i><br>Received: <i>by with SMTP id 15mr5939412nzc; Tue, 15 Nov 2005 20:57:10 -0800 (PST)</i><br>Received: <i>from ( []) by with ESMTP id 23sm199490nzn.2005.; Tue, 15 Nov 2005 20:57:09 -0800 (PST)</i><br>Received: <i>from [] ( [])(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))(No client certificate requested)by (Postfix) with ESMTP id DC824184063;Wed, 16 Nov 2005 13:57:02 +0900 (KST)</i><br>&gt;Jones Joneser wrote:<br>&gt; &gt; Machine:<br>&gt; &gt; Tyan s2822G3NR-D<br>&gt; &gt; Silicon Image, Inc. SiI 3114<br>&gt; &gt; SATA Drives: Western Digital 300gb / seagate 80 gb<br>&gt; &gt;<br>&gt; &gt; Initially we thought we had a network issue because we were seeing a<br>&gt; &gt; slowdown when transferring files &gt; 512Mb in size (by whatever method:<br>&gt; &gt; rsync, cp, scp, etc.) between two of the Tyan servers, we see the first<br>&gt; &gt; 512Mb go at a decent rate (tens of megabytes per second) and then the<br>&gt; &gt; rate plummets to below 500k/sec. However we reproduce the issue<br>&gt; &gt; locally on a machine thus eliminating the network card issue. We also<br>&gt; &gt; had tried with different ethernet cards and x-over cable.<br>&gt; &gt;<br>&gt; &gt;<br>&gt; &gt; We are using CentOS 4 and have tried both 4.1 and 4.2 (the latest<br>&gt; &gt; edition) 64 and 32 bit. We have tried ubuntu, gentoo, and vanilla<br>&gt; &gt; kernels. We have upgraded our BIOS to the latest and experimented with<br>&gt; &gt; different BIOS settings (from 'safe' to 'optimal' with many variants in<br>&gt; &gt; between.) We have tried it with ACPI switched off, with 4gb of RAM and<br>&gt; &gt; with 8gb of RAM. We have upgraded the BIOS to 3.04 &amp; then 3.05. The<br>&gt; &gt; best we get is that under the ubuntu, gentoo, and a 2.4 kernel we can<br>&gt; &gt; see stable performance that is well below what we should be getting<br>&gt; &gt; ~20MiB/s.<br>&gt; &gt;<br>&gt; &gt; No matter what combination of configuration we try, we consistently see<br>&gt; &gt; this issue. We have even tried and LSI SATA controller w/ Tyan<br>&gt; &gt; motherboard and experienced the same issues.<br>&gt; &gt;<br>&gt; &gt; We moved the SATA controller to a Dell PE 1750 and experience none of<br>&gt; &gt; the slowdowns, consistent ly 45-50MiB/s performance with no erraticness<br>&gt; &gt; in speed or drops in performance.<br>&gt; &gt;<br>&gt; &gt; We suspect the issue is related to the combo of the Tyan mobo with the<br>&gt; &gt; SATA controller subsystem but need some assistance in further nailing<br>&gt; &gt; down the cause and solution to this issue.<br>&gt; &gt;<br>&gt; &gt; Let me know of any additional information that I can provide to assist<br>&gt; &gt; with the debugging of this issue.<br>&gt; &gt;<br>&gt; &gt; Thanks,<br>&gt; &gt; -asher<br>&gt; &gt;<br>&gt;<br>&gt;i. posting boot message would help.<br>&gt;ii. Can you try vanilla 2.6.14 kernel? If it's sil m15w problem and<br>&gt;your card is 3114 but not 3112, the problem should disappear on 2.6.14.<br>&gt;<br>&gt;--<br>&gt;tejun<br>&gt;-<br>&gt;To unsubscribe from this list: send the line &quot;unsubscribe linux-scsi&quot; in<br>&gt;the body of a message to majordomo@xxxxxxxxxxxxxxx<br>&gt;More majordomo info at<br></font></BLOCKQUOTE>

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at