SATA ICH6M problems on Sharp M4000

From: Josh Litherland
Date: Mon Nov 21 2005 - 17:33:36 EST

Trying to get this laptop operational; it has SATA for the hard disc and
PATA for the optical drive. The hard drive is wired to the secondary
IDE interface, the optical to the primary. As it stands, driving the
whole system with the PATA (piix) driver works, but performance for the
hard disc is (predictably) extremely poor. With ata_piix driving the
hard drive, performance is great, but the optical device is never
enumerated. When the piix driver tries to load, the following occurs:

ide0: I/O resource 0x1F0-0x1F7 not free.
ide0: ports already in use, skipping probe
ide1: I/O resource 0x170-0x177 not free.
ide1: ports already in use, skipping probe

We have tried to resolve this through a wide variety of kernel command
line options. Tried every combination we could think of of ide0=0x1f0,
ide1=0x170, ide0=noprobe, ide1=noprobe, acpi=off, noapic, lapic,
pci=routeirq. Tried shaking up module load order and using ide-generic
instead of piix. ahci won't bind to the device; throws error -12.

Some information about this system including dmesg and lspci:

Thanks in advance for any advice you can give.

Josh Litherland (josh@xxxxxxxxxxxxxxxx)
Emperor Linux, Inc.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at