Console rotation problems

From: Benjamin Herrenschmidt
Date: Wed Nov 23 2005 - 19:49:17 EST

Hi Antonio !

I decided to give a quick test to console rotation on my g5 (radeonfb)
and couldn't get it to work.

When I tried echo'ing something in con_rotate, something very strange

pogo:/sys/class/graphics/fb0# echo "1" >con_rotate

As you can see, it looks like I pressed ctrl-D (which I didn't do) and
thus exited my shell session. Thus my shell session got killed some way.
Verified it twice. Also the console stopped displaying anything (that
is,whatever was displayed was still there but the cursor didn't blink
anymore and no new stuff got displayed).

When I then tried to echo "0" back there, it just hung in the kernel
(probably on a semaphore, I could still use the box for a little while
before it completely locked up).


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at