Re: [openib-general] Re: 2.6.16-rc6-mm2: new RDMA CM EXPORT_SYMBOL's
From: Sean Hefty
Date: Mon Mar 20 2006 - 14:16:57 EST
Roland Dreier wrote:
Looking at this list of exports, I do see a couple of things that
could maybe be improved:
> +EXPORT_SYMBOL(rdma_wq);
> +EXPORT_SYMBOL(rdma_translate_ip);
> +EXPORT_SYMBOL(rdma_resolve_ip);
> +EXPORT_SYMBOL(rdma_addr_cancel);
First, rdma_wq seems like a strange internal thing to be exporting.
Sean, why does more than one module need to use the same workqueue?
This is simply an attempt to reduce/combine work queues used by the Infiniband
code. This keeps the threading a little simpler in the rdma_cm, since all
callbacks are invoked using the same work queue. (I'm also using this with the
local SA/multicast code, but that's not ready for merging.)
Second, the naming of rdma_addr_cancel() is not that symmetric with
the rdma_{translate,resolve}_ip() functions. Unfortunately I'm just
clever enough to criticize, not clever enough to come up with a better
suggestion.
rdma_resolve_ip() is the operation actually being canceled if that makes it
easier to come up with a better name.
- Sean
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/