Re: [PATCH] pids: simplify do_each_task_pid/while_each_task_pid

From: Eric W. Biederman
Date: Thu Apr 13 2006 - 13:53:23 EST


Christoph Hellwig <hch@xxxxxxxxxxxxx> writes:

> On Fri, Apr 14, 2006 at 12:21:04AM +0400, Oleg Nesterov wrote:
>> #define
> NEW_IMPROVED_HLIST_FOR_EACH_ENTRY_RCU_WHICH_DOESNT_NEED_EXTRA_PARM(pos, head,
> member) \
>> for (pos = hlist_entry((head)->first, typeof(*(pos)), member); \
>> rcu_dereference(pos) != hlist_entry(NULL, typeof(*(pos)), member) \
>> && ({ prefetch((pos)->member.next); 1; }); \
>> (pos) = hlist_entry((pos)->member.next, typeof(*(pos)), member))
>>
>> What do you think? What should be the name for it?
>
> Justy kill the superflous argument from all hlist_for_each_entry variants
> without a name change.

Sounds like a plan.

I didn't attack this in the orignal patch that made it possible
because it would have all been noise there.

But as two independent cleanups it sounds reasonable.

Eric

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/