Re: [RFC][PATCH] A generic boolean (version 2)

From: ricknu-0
Date: Fri Jul 21 2006 - 18:14:40 EST

Citerar Jeff Garzik <jeff@xxxxxxxxxx>:

> Michael Buesch wrote:
> > On Friday 21 July 2006 16:23, Jan Engelhardt wrote:
> >>> The changes are:
> >>> * u2 has been corrected to u1 (and also added it as __u1)
> >> Do we really need this? Is not 'bool' enough?
> >
> > I would say we don't even _want_ this.
> > A u1 variable will basically never be one bit wide.
> > It will be at least 8bit, or let's say 32bit. Maybe
> > even 64bit on some archs. It all depends on the compiler
> > plus the arch.
> >
> > We _don't_ want u1, because we don't get what we see.
> For this and 1000 other reasons, we don't want u1.

This is a classic "do what others have done (with some modifications) and not
give a thought about it"... it's gone!
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at