Re: A CodingStyle suggestion

From: Richard Knutsson
Date: Sat Feb 03 2007 - 17:56:38 EST


Ahmed S. Darwish wrote:
Hi all,

In CodingStyle Chapter 16 "Function return value and names", why not
adding a comment about the favorable community way of checking the return
value. ie:

ret = do_method();
if (ret) {
/* deal with error */
}

and not other ways like:

if (do_method()) or
So:

if (is_true()) {
/* do something */
}

is alright then? If so, I agree, but please make it real clear in the document ;)

Richard Knutsson

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/