Re: A CodingStyle suggestion
From: Manu Abraham
Date: Sun Feb 04 2007 - 07:37:07 EST
On 2/4/07, Ahmed S. Darwish <darwish.07@xxxxxxxxx> wrote:
Hi all,
In CodingStyle Chapter 16 "Function return value and names", why not
adding a comment about the favorable community way of checking the return
value. ie:
ret = do_method();
if (ret) {
/* deal with error */
}
and not other ways like:
if (do_method()) or if ((ret = do_method()) > value) ...
if we have some 100 lines of
ret = do_method()
if (ret) {
/* error handling */
}
This is going to additionally increase the number of lines of unnecessarily.
IMHO, when you have a large number of lines which do a similar thing ..
if ((ret = do_method()) < value)
goto err;
could greatly reduce the number of lines, otherwise.
manu
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/