Re: [rfc] lock bitops

From: Matthew Wilcox
Date: Tue May 08 2007 - 11:32:40 EST


On Tue, May 08, 2007 at 01:37:09PM +0200, Nick Piggin wrote:
> --
> Introduce test_and_set_bit_lock / clear_bit_unlock bitops with lock semantics.
> Add non-trivial for powerpc and ia64. Convert page lock, buffer lock,
> bit_spin_lock, tasklet locks to use the new locks.

The names are a bit clumsy. How about naming them after the effect,
rather than the implementation? It struck me that really these things
are bit mutexes -- you can sleep while holding the lock. How about
calling them bit_mutex_trylock() and bit_mutex_unlock()?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/