Re: [Patch 09/16] Remove unnecessary kmalloc casts in the pcisubsystem.

From: Greg KH
Date: Tue Jul 31 2007 - 13:49:03 EST


On Tue, Jul 31, 2007 at 06:20:29PM +0200, Andreas Schwab wrote:
> Greg KH <gregkh@xxxxxxx> writes:
>
> > On Tue, Jul 31, 2007 at 10:46:19PM +0800, WANG Cong wrote:
> >> However, I think using resource_size_t is a bit better than unsigned long,
> >> so that we don't need to check the defination of it.
> >>
> >> - res->start = (unsigned long)kmalloc(*size, GFP_KERNEL);
> >> + res->start = (resource_size_t)kmalloc(*size, GFP_KERNEL);
> >>
> >> Is this change OK?
> >
> > Yes, that is the proper cast to have here.
>
> It will generate a warning when resoure_size_t is 64bit on a 32bit arch.

How? And if so, what should the proper cast be?

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/