[RFC] kobject_init changes
From: Greg KH
Date: Fri Nov 30 2007 - 14:56:54 EST
New thread time...
Here are two patches, one that adds a two new functions,
kobject_init_ng() and kobject_init_and_add() and then a patch that shows
how a number of different users are converted over to these new
functions.
I choose the name "kobject_init_ng()" for now, so that I can do a patch
series that converts the differnet usages in the kernel tree, and then
do a global rename all at once, making it easier to find any potential
problems that might happen.
Same goes for the _and_add() function, which is really just
kobject_register() but without the uevent call, and it has proper memory
cleanup.
Any objections to these changes?
My plans with this are:
- clean up the rest of the kernel tree usages of kobject_init()
- rename kobject_init_ng() to kobject_init().
- remove all users of kobject_register() and use the new
functions and a uevent call.
- fix up the new kobject_create_and_register() function to be
create_and_add() instead.
The last one will require some patch reworking in my tree, but I have
four days of meetings next week, and two plane rides, so I'll need
something real to do :)
I suppose if I really get bored, I can fix up the cdev stuff, but that's
going to take a lot more work...
thanks,
greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/