On Sun, Feb 10, 2008 at 02:25:20PM +0100, Jan Kiszka wrote:Sam Ravnborg wrote:...This is a leftover from the old jmp-on-fault logic that was missed by
+extern int kgdb_may_fault;
I searched but I could not find any places this
variable were set to anuthing else than 0 neither where it was tested.
this tree. I have a patch under test that kills this (and further 150
LOC) from the core.
diff --git a/lib/Kconfig.kgdb b/lib/Kconfig.kgdbIs the patch below OK? I also added an "if KGB" to unbreak kgdb's
new file mode 100644
index 0000000..00263c0
--- /dev/null
+++ b/lib/Kconfig.kgdb
@@ -0,0 +1,37 @@
+
+menuconfig KGDB
+ bool "KGDB: kernel debugging with remote gdb"
+ select FRAME_POINTER
+ depends on HAVE_ARCH_KGDB
+ depends on DEBUG_KERNEL && EXPERIMENTAL
+ help
+ If you say Y here, it will be possible to remotely debug the
+ kernel using gdb. Documentation of kernel debugger is available
+ at http://kgdb.sourceforge.net as well as in DocBook form
+ in Documentation/DocBook/. If unsure, say N.
+
+config HAVE_ARCH_KGDB_SHADOW_INFO
+ bool
+
Please add:
config HAVE_ARCH_KGDB
bool
So we later in x86/Kconfig can do:
config X86
select HAVE_ARCH_KGDB
And we can get rid of (from x86/Kconfig):
+config HAVE_ARCH_KGDB
+ def_bool y
Back to Kconfig.kgdb:
+config KGDBOC
+ tristate "KGDB: use kgdb over the serial console"
+ depends on KGDB
Can we have a more descriptive name here.
For example:
config KGDB_SERIAL_CONSOLE
It is only used in one place so there is no
specific need for such a magic short name.
kconfig menu again and included two minor cleanups I posted yesterday.
Looks OK - but I think Ingo already addressed this.
Attachment:
signature.asc
Description: OpenPGP digital signature