On Thu, 2008-02-14 at 12:30 -0600, Corey Minyard wrote:Someone else asked about this, and I wasn't too sure. It seems from the CodingStyle document that enums are preferred for things like this, but I current kernel code seems a mixed bag. An enum is cleaner and more reliable, IMHO. I'll convert it, I think.
+/* The command didn't have anyone waiting for it. */
+#define IPMI_STAT_unhandled_commands 23
+
+/* Invalid data in an event. */
+#define IPMI_STAT_invalid_events 24
+
+/* Events that were received with the proper format. */
+#define IPMI_STAT_events 25
+
+/* When you add a statistic, you must update this value. */
+#define IPMI_NUM_STATS 26
This shouts enum to me..