Re: [PATCH] [6/13] Core maskable allocator

From: Jonathan Corbet
Date: Tue Mar 11 2008 - 11:35:01 EST


Hi, Andi,

As I dig through this patch, I find it mostly makes sense; seems like it
could be a good idea. I did have one little API question...

> +struct page *
> +alloc_pages_mask(gfp_t gfp, unsigned size, u64 mask)
> +{
> + unsigned long max_pfn = mask >> PAGE_SHIFT;

The "mask" parameter isn't really a mask - it's an upper bound on the
address of the allocated memory. Might it be better to call it
"max_addr" or "limit" or "ceiling" or some such so callers understand
for sure how it's interpreted? The use of the term "mask" throughout
the interface could maybe create a certain amount of confusion.

Thanks,

jon
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/