Re: [PATCH] x86: simplify sync_test_bit()

From: Jeremy Fitzhardinge
Date: Fri Mar 14 2008 - 11:45:26 EST


Jan Beulich wrote:
I'm usually intentionally using just the names, without parameters and
not as inline, in such alias definitions so that in case the name gets used
as a function pointer (arguably unlikely here) there's not going to be
any missing definition or duplicate function instantiation. But from a
functionality point of view, either of the alternatives you suggest is
of course as good.

I'm especially wary of the naked #define, since it will affect any instance of sync_test_bit:

struct bit_thingy {
unsigned sync_test_bit:1;
unsigned other_test_bit:1;
...
};

J
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/