These locks don't nest so being in the same class should be okay and I was following what (at least some of) other __SPIN_LOCK_UNLOCKED users are doing. If putting these locks into separate classes is the RTTD, sure.
Ah, they'll actually be in seprate classes all of the same name. So I
think it is cleaner to cause them to have separate names too.
see look_up_lock_class() in kernel/lockdep.c:
/*
* Static locks do not have their class-keys yet - for them the key
* is the lock object itself:
*/
if (unlikely(!lock->key))
lock->key = (void *)lock;