On Wed, 25 Jun 2008 14:08:57 -0700
Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
Arjan van de Ven wrote:
it's more readable for several of these cases to stick a barrier();I suppose, though I would be inclined to put the barriers in the
in front and after it to be honest; that makes it more explicit that
these are deliberate compiler barriers rather than "actual" memory
access...
wrmsr macro itself to act as documentation.
yeah I meant like this:
static inline void native_write_msr(unsigned int msr,
unsigned low, unsigned high)
{
barrier();
asm volatile("wrmsr" : : "c" (msr), "a"(low), "d" (high));
barrier();
}
or in the same in the thing that calls this.