... and wouldn't uv_bios_strerror/uv_bios_freq_base be better names?
The plan is for both x86 and ia64 versions of uv, with this being
the x86 version. The ia64 version has ia64_sal_strerror()
and ia64_sal_freq_base(). Hence the x86_bios_* naming convention.
I'm not strongly tied to that convention, it just seemed logical.
Here is the updated patch.
+enum {
+ BIOS_STATUS_SUCCESS = 0,
+ BIOS_STATUS_UNIMPLEMENTED = -1,
+ BIOS_STATUS_EINVAL = -2,
+ BIOS_STATUS_ERROR = -3
+};
+extern long
+x86_bios_freq_base(unsigned long which, unsigned long *ticks_per_second,
+ unsigned long *drift_info);
+static __init void uv_rtc_init(void)
+{
+ unsigned long status, ticks_per_sec, drift;