On Mon, 2008-09-08 at 14:02 +0200, Pierre Morel wrote:I have read your suggestion, but the actual ptrace() implementation uses explicit reference to the different architecture dependent registers and I think that this portion of code is more readable if the patch keeps the actual conventions used by Roland.
+ if (is_self_ptracing(regs->gprs[2])) {
+ if (!entryexit) {
+ struct siginfo info;
+
+ memset(&info, 0, sizeof(struct siginfo));
+ info.si_signo = SIGSYS;
+ info.si_code = SYS_SYSCALL;
+ info.si_errno = regs->gprs[2];
+ info.si_addr = (void *)regs->orig_gpr2;
+ send_sig_info(SIGSYS, &info, current);
+ regs->gprs[2] = -1;
+ }
+ return;
+ }
I see you didn't like my suggestions for consolidating some of these
repetitive code bits across all the architectures. Did you give that a
a shot? Would you like me to produce a patch on top of what you haveNo Dave, thank you.
here before this gets merged into mm?
-- Dave
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/