On Tue 2009-03-17 17:06:46, Nitin Gupta wrote:It was named compcache according to its original goal:drivers/block/Kconfig | 22 +
drivers/block/Makefile | 1 +
drivers/block/compcache.c | 995 +++++++++++++++++++++++++++++++++++++++++++++
drivers/block/compcache.h | 160 ++++++++
4 files changed, 1178 insertions(+), 0 deletions(-)
Creates RAM based block device (ramzswap0) which can be used as swap device.
Pages swapped to this are compressed and stored in memory itself.
The module is called compcache.ko. It depends on:
- xvmalloc.ko: memory allocator
- lzo_compress.ko
- lzo_decompress.ko
See Documentation/blockdev/compcache.txt for usage details.
Project home: http://code.google.com/p/compcache/
Compcache is really bad name for this. zramdisk? gzrd?
Is the block device useful for general filesystem storage?No. It can only handle page aligned I/O. But it shouldn't be too hard