Re: [PATCH] Improve vmlinux.lds.h support for arch specific linkerscripts
From: Tim Abbott
Date: Fri Jun 12 2009 - 10:52:41 EST
On Sun, 7 Jun 2009, Sam Ravnborg wrote:
> Please review and comment..
> It will be part of kbuild-next.git
This patch looks great. I have a few very minor comments.
> + * /DISCARD/ : {
> + * EXIT_TEXT
> + * EXIT_DATA
> + * *(.exitcall.exit)
> + * }
I recommend adding
#define EXIT_CALL *(.exitcall.exit)
and using it in the DISCARD section of the sample linker script so that
the sample linker script doesn't use any raw section names.
> +#define BSS_SECTION(sbss_align, bss_align) \
> + SBSS \
> + BSS(bss_align) \
> + . = ALIGN(4); \
This macro should end with the 'ALIGN(4);' -- there's an extra backslash
at the end of the line.
I recommend changing HEAD_SECTION to HEAD_TEXT_SECTION to better fit the
naming scheme. This would involve deleting the recently added
include/linux/section-names.h and going back to hardcoding .head.text in
include/linux/init.h (given the way these macros have turned out,
include/linux/section-names.h doesn't really make sense).
Also, the commit message misspells 'alignment', 'linker', and 'Abbott'.
-Tim Abbott
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/