[KVM PATCH v7 0/2] iosignalfd

From: Gregory Haskins
Date: Tue Jun 16 2009 - 09:42:51 EST


(Applies to kvm.git/master:c27b64a0)

This is v7 of the series. For more details, please see the header to
patch 2/2.

This series has been tested against the kvm-eventfd unit test, and
appears to be functioning properly. You can download this test here:

ftp://ftp.novell.com/dev/ghaskins/kvm-eventfd.tar.bz2

Please consider for inclusion to kvm.git

[
Changelog:

v7:
*) Implemented a resource limit (CONFIG_KVM_MAX_IOSIGNALFD_ITEMS)
to limit malicious/broken userspace from consuming arbitrary
kernel memory.
*) Rebased to kvm.git/master:c27b64a0, which already includes
Marcelo's irq-lock rework.

v6:
*) Removed "FIXME?" comment on choice over RCU vs SRCU after
discussion/numbers from Paul. I think RCU is fine to use for
now based on the conversation. We can always convert it later
if need be.
*) Fixed the "group" free path to eliminate an RCU related race
*) Fixed a memory/eventfd leak on shutdown for any iosignalfd's
which were still active at the time the guest shuts down.
*) Beefed up comments
*) Rebased to kvm.git/master:0281e88f + irq locking rework and
verified that kvm-eventfd unit test still passes.

v5:
*) Removed "cookie" field, which was a misunderstanding on my
part on what Avi wanted for a data-match feature
*) Added a new "trigger" data-match feature which I think is
much closer to what we need.
*) We retain the dev_count field in the io_bus infrastructure
and instead back-fill the array on removal.
*) Various minor cleanups
*) Rebased to kvm.git/master:25deed73

v4:
*) Fixed a bug in the original 2/4 where the PIT failure case
would potentially leave the io_bus components registered.
*) Condensed the v3 2/4 and 3/4 into one patch (2/2) since
the patches became interdependent with the fix described above
*) Rebased to kvm.git/master:74dfca0a

v3:
*) fixed patch 2/4 to handle error cases instead of BUG_ON
*) implemented same HAVE_EVENTFD protection mechanism as
irqfd to prevent compilation errors on unsupported arches
*) completed testing
*) rebased to kvm.git/master:7391a6d5

v2:
*) added optional data-matching capability (via cookie field)
*) changed name from iofd to iosignalfd
*) added io_bus unregister function
*) implemented deassign feature

v1:
*) original release (integrated into irqfd v7 series as "iofd")
]

---

Gregory Haskins (2):
KVM: add iosignalfd support
KVM: make io_bus interface more robust


arch/x86/kvm/Kconfig | 8 +
arch/x86/kvm/i8254.c | 22 ++
arch/x86/kvm/i8259.c | 9 +
arch/x86/kvm/x86.c | 3
include/linux/kvm.h | 15 ++
include/linux/kvm_host.h | 16 +-
virt/kvm/Kconfig | 2
virt/kvm/coalesced_mmio.c | 8 +
virt/kvm/eventfd.c | 402 +++++++++++++++++++++++++++++++++++++++++++++
virt/kvm/ioapic.c | 9 +
virt/kvm/kvm_main.c | 41 ++++-
11 files changed, 520 insertions(+), 15 deletions(-)

--
Signature
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/