Re: [PATCH 06/17] vfs: Rename generic_file_aio_write_nolock

From: Christoph Hellwig
Date: Fri Aug 21 2009 - 13:30:43 EST


On Fri, Aug 21, 2009 at 07:23:56PM +0200, Jan Kara wrote:
> generic_file_aio_write_nolock() is now used only by block devices and raw
> character device. Filesystems should use __generic_file_aio_write() in case
> generic_file_aio_write() doesn't suit them. So rename the function to
> device_aio_write().

This might turn into nitpicking, but it's really only useful for
writing to block devices. Raw isn't a real character interface but
basically a convuled way to open a block device using O_DIRECT.

So I would recommend to renamed it to blkdev_aio_write, move it to
fs/block_dev.c and stop exporting it.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/