Re: [PATCH] Rename rar_driver to rar_register

From: Greg KH
Date: Mon Jan 18 2010 - 19:15:22 EST

On Mon, Jan 18, 2010 at 01:45:58PM -0800, Marcel Holtmann wrote:
> Hi Mark,
> > The purpose of this patch is to change the name of rar_register source
> > files (both the .c and .h files) to rar_register.
> >
> > This is the first of seven patches for the rar_register driver
> > for Sunday, January 17, 2009
> >
> > This is to clarify that this driver is for the rar_register.
> >
> > This patch only changes the names. It does not make any changes in
> > any code.
> >
> > Any checkpatch errors on this code were from the original code. They
> > will be addressed in future patches.
> >
> > The rar stands for restricted access region. The restricted access
> > region is an area of memory that can be locked from access by the
> > x86 processor.
> >
> > The purpose of the restricted access region is to safeguard confidential
> > information from any unauthorized software running on the x86 processor.
> >
> > The purpose of this driver is to enable other drivers to obtain
> > the address ranges of the restricted regions as well as lock them.
> >
> > This patch is referenced off the linux-next repository as pulled
> > on Sunday, January 17, 2010
> this is a lot of boilerplate that you repeat for every patch in this
> series. It distracts from the actual change you are making. I would
> prefer if you send an introductory/summary email and then focus the
> commit message on the actual change you are making.

As the person who has to edit these commit messages down to nothing, I
totally agree. Please follow the proper submission guidelines for
patches as described in the Documentation/ directory.

Can you resend all of these please based on that?


greg k-h
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at