Re: [PATCH 2/3] perf_event: cleanup for event profile buffer operation

From: Xiao Guangrong
Date: Mon Jan 18 2010 - 20:28:28 EST

Masami Hiramatsu wrote:
> Frederic Weisbecker wrote:
>> On Mon, Jan 18, 2010 at 11:21:46AM -0500, Masami Hiramatsu wrote:
>>> Hmm, could you make it inline-functions or add __kprobes?
>>> Because it is called from kprobes, we don't want to probe
>>> the function which will be called from kprobes handlers itself.
>>> (IMHO, from the viewpoint of performance, inline-function
>>> could be better.)
>>> Thank you,
>> Yeah, may be inline ftrace_profile_buf_end, would be better.
>> But we shouldn't inline ftrace_profile_buf_begin() I guess,
>> considering its size.
> Indeed, especially for events...

Thanks Masami and Frederic, i'll fix it in the next version

>> While at it, may be let's choose more verbose names
>> like
>> ftrace_profile_buf_fill() and ftrace_profile_buf_submit().
>> Also, profile is a bit of a misnomer. Not a problem since
>> ftrace_profile_templ_##call() is already a misnomer, but
>> we should start a bit of a rename. Sometimes, perf only
>> profiles trace events as counters and sometimes it records
>> the raw samples too.
>> So, as more generic names, I would suggest:
>> ftrace_perf_buf_fill() and ftrace_perf_buf_submit().
> Actual filling buffer is done in the profile handlers,
> so I think ftrace_perf_buf_prepare() may be better :-)
> ftrace_perf_buf_submit is good to me:-)

OK, i'll rename those functions and add __kprobe for ftrace_perf_buf_prepare(),
i guess i can add you Acked-by :-)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at