Hi all, bug or design flaw?

From: Stepan Chatalyan
Date: Thu Jan 21 2010 - 20:05:59 EST

Hi there,

I'm Stepan G. Chatalyan, and i think that I discovered a bug or design
flaw... and I don't know that it is provide from kernel...

Let's see:

(1) I mount /tmp with noexec,nosuid,nodev options

/dev/hda6 on /tmp type ext3 (rw,noexec,nosuid,nodev,relatime)

(2) I went to 'cd /tmp'`and I created a bash script, or another script
(perl, python, etc)... and chmod +x createdfile
script cointain:

echo "Probe..."

(3) I tried to execut it with "./createdfile"
[kehcho@kehcho] [/tmp]$ ./createdfile
-bash: ./createdfile: /bin/bash: bad interpreter: Permission denied

(4) I tried to execute it, but pass to bash ". /tmp/createdfile"

[kehcho@tornadowt] [/tmp]$ . /tmp/createdfile

It is a kernel bug or I just report a another one?


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/