Re: sata_nv times out for BD-ROM iHOS104-08

From: Tejun Heo
Date: Sat Jan 23 2010 - 03:55:32 EST


On 01/22/2010 11:11 PM, Cengiz Günay wrote:
> On Tue, Jan 19, 2010 at 9:59 PM, Robert Hancock <hancockrwd@xxxxxxxxx> wrote:
>>>> 2009/12/24 Tejun Heo <tj@xxxxxxxxxx>:
>>> Hmm.... it worked? Does kernel parameter sata_nv.adma_enabled=0 make
>>> any difference? Can you please attach boot log with the kernel
>>> parameter specified?
>> Think you meant maybe sata_nv.swncq=0 instead - this is an MCP51
>> controller so it doesn't support ADMA. I don't imagine SWNCQ would
>> make any difference with an ATAPI device, but wouldn't hurt to try.
> Thanks for following this up. I tried both of your suggested kernel
> parameters (attached). Neither solved my problem, but also it looks
> like I couldn't turn off the SWNCQ mode. Even though I set it to zero,
> sata_nv still shows that it uses it. Although the order of my devices
> changed, so I assume it did something.

The parameter isn't being passed to the module loaded by initrd. You
probably need to edit modules.conf and then regenerate initrd. :-(

> I hope this helps shed some light! I will also try the kernel patch --
> not sure if that is suited for the problem I'm having?

Yeah, I was about to suggest trying the patch. It could be that the
timeout used by the new TUR code is too aggressive.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at