Re: [PATCH] ata: Disable NCQ for Crucial M225 brand SSDs

From: Vishal Rao
Date: Tue Jan 26 2010 - 19:21:25 EST

2010/1/27 David Rees <drees76@xxxxxxxxx>:
> Have there been any other reports of NCQ issues with similar Crucial
> drives or Indilinx?

I haven't personally seen reports of NCQ specific issues. I have seen
people (online) reporting "issues" with Linux distro installations
hanging/freezing etc. and some prior attempts at SMART fixes which
I also initially tried but did not work for me.

I have tried to "publicise" this issue (forum, blog, mailing list posts)
in the hope more users may search and identify the correct issue
so that it may be better verified.

Unfortunately, the Crucial ID string is not model-agnostic (if thats
the right term)... meaning the patch has 3 lines to ID the 3 current
models that I know of including my own 128 GB model.

Not sure if there's a better, more generic way to match a whole group
of SSDs (same model family or various vendors) which trigger NCQ errors?

"Thou shalt not follow the null pointer for at its end madness and chaos lie."
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at