+static struct mfd_cell lpc_sch_cells[] = {
+ {
+ .name = "isch_smbus",
+ .num_resources = 1,
+ .resources = &smbus_sch_resource,
+ },
+ {
+ .name = "sch_gpio",
+ .num_resources = 1,
+ .resources = &gpio_sch_resource,
+ },
+};
These names are nicely inconsistent. What about "isch_gpio"?
+obj-$(CONFIG_LPC_SCH) += lpc_sch.o
I don't like this name either. There is another vendor (SMSC) shipping
LPC devices with "SCH" in their names, so there is room for confusion.
"isch" makes it clearer that we are talking about the Intel ones.