On Mon, Mar 08, 2010 at 11:17:41AM +0200, Avi Kivity wrote:
On 03/03/2010 09:12 PM, Joerg Roedel wrote:Hmm, how about renaming the global tdp_enabled variable to tdp_usable?
This patch changes the tdp_enabled flag from its globalThis needs a different name, since the old one is still around.
meaning to the mmu-context. This is necessary for Nested SVM
with emulation of Nested Paging where we need an extra MMU
context to shadow the Nested Nested Page Table.
diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h
index ec891a2..e7bef19 100644
--- a/arch/x86/include/asm/kvm_host.h
+++ b/arch/x86/include/asm/kvm_host.h
@@ -254,6 +254,7 @@ struct kvm_mmu {
int root_level;
int shadow_root_level;
union kvm_mmu_page_role base_role;
+ bool tdp_enabled;
Perhaps we could call it parent_mmu and make it a kvm_mmu pointer.
The global variable indicates if tdp is _usable_ and we can _enable_ it
for a mmu context.