Re: [PATCH] firmware class: export nowait to userspace

From: Kay Sievers
Date: Thu Mar 11 2010 - 23:22:16 EST

On Thu, Mar 11, 2010 at 23:56, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote:
> When we use request_firmware_nowait(), userspace may
> not want to answer negatively right away when for
> example it is answering from an initrd only, but
> with request_firmware() it has to in order to not
> delay the kernel boot until the request times out.
> This allows userspace to differentiate between the
> two in order to be able to reply negatively to async
> requests only when all filesystems have been mounted
> and have been checked for the requested firmware file.

The firmware_class already always exports a TIMEOUT= value, right? If
this is the case, it should be set to 0, I guess.

Sounds fine to have a flag like this, while "NOWAIT" is, I guess, a
pretty bad name from the event perspective. This name might make sense
for the called kernel function, but not so much for a firmware loader

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at