Re: [PATCH] Fix array overflow in CFQ
From: Andi Kleen
Date: Tue Oct 19 2010 - 09:23:31 EST
slice = group_slice * count /
max_t(unsigned, cfqg->busy_queues_avg[cfqd->serving_prio],
cfq_group_busy_queues_wl(cfqd->serving_prio, cfqd,
cfqg));
So for IDLE class, we return immediately from the function and never
execute cfqg->busy_queues_avg[IDLE].
Hmm that's true. But why do you put this into a global variable anyways,
can't it
just be a local?
Now to remove the gcc warning we can increase the size of busy_queues_avg[]
array but third field should always remain unused.
It's better to increase the field still I think.
-Andi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/