Re: [PATCH 6/8] Add __GFP_OTHER_NODE flag
From: Andi Kleen
Date: Tue Feb 22 2011 - 17:52:24 EST
You could make the same argument for anything using kmalloc_node() since
preferred_zone may very well not be on the allocating cpu's node.
You're right. It is not always, that is why I defined a new flag. In the
cases where the flag
is passed it is.
So you
either define NUMA_LOCAL to account for when a cpu allocates memory local
to itself (as it's name implies) or you define it to account for when
memory comes from the preferred_zone's node as determined by the zonelist.
That's already numa_hit as you say.
I just don't think "local to some random kernel daemon that means
nothing to the user"
is a useful definition for local_hit.
When I defined the counter I intended it to be local to the user
process. It always was like
that too, just THP changed the rules.
-Andi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/