[SOLVED: r8169 is the culprit] Re: 2.6.39, 3.0.0-rc7+: complete system freeze with rsync on big directory

From: Michael Brade
Date: Sat Aug 13 2011 - 18:17:51 EST


finally I found the reason for my system freeze: the r8169 module. The freeze
happens only on heavy network loads, i.e. > 70 MB/s. iSCSI is really fast,
that's why I only saw the freezes with iSCSI.

> But watching the normal console I get loads of
> r8169 0000:13:00.0: eth0: link up
> r8169 0000:13:00.0: eth0: link up

This does not happen with, and the system doesn't freeze either with
this kernel. So the r8169 is fine on 2.6.32.x. 2.6.37 and above freeze the
system. I haven't tried any kernel in between .32 and .37.

> [...]
> lspci:
> 13:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B
> PCI Express Gigabit Ethernet controller (rev 03)

The solution with 2.6.37 and above: use the r8168 module from the realtek
website. I have tested it with >30 GB at rates of 112 MB/s and experienced no
freeze anymore.

I don't know if you are interested in fixing r8169 but if so and you need
anything, let me know how I can help.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/