Re: x86 memcpy performance

From: Andrew Lutomirski
Date: Mon Aug 15 2011 - 12:58:50 EST

On Mon, Aug 15, 2011 at 12:12 PM, H. Peter Anvin <hpa@xxxxxxxxx> wrote:
> On 08/15/2011 08:36 AM, Andrew Lutomirski wrote:
>> (*)  kernel_fpu_begin is a bad name.  It's only safe to use integer
>> instructions inside a kernel_fpu_begin section because MXCSR (and the
>> 387 equivalent) could contain garbage.
> Uh... no, it just means you have to initialize the settings.  It's a
> perfectly good name, it's called kernel_fpu_begin, not kernel_fp_begin.

I prefer get_xstate / put_xstate, but this could rapidly devolve into
bikeshedding. :)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at