Re: [PATCH 3/4] dynamic_debug: use a single printk() to emit msgs

From: Jason Baron
Date: Mon Aug 29 2011 - 15:15:22 EST


On Fri, Aug 26, 2011 at 03:47:49PM -0600, Jim Cromie wrote:
> On Thu, Aug 25, 2011 at 11:34 AM, Jason Baron <jbaron@xxxxxxxxxx> wrote:
>
> > +       if (desc->flags & _DPRINTK_FLAGS_INCL_MODNAME)
> > +               pos += snprintf(buf + pos, LEFT(pos), "%s:", desc->modname);
> > +       if (desc->flags & _DPRINTK_FLAGS_INCL_FUNCNAME)
> > +               pos += snprintf(buf + pos, LEFT(pos), "%s:", desc->function);
> > +       if (desc->flags & _DPRINTK_FLAGS_INCL_LINENO)
> > +               pos += snprintf(buf + pos, LEFT(pos), "%d ", desc->lineno);
>
> this inserts a space after lineno, but not otherwize.
>
> I have patch to fix it, but maybe you want to fix it it here ?
>

Hi Jim,

Thanks for your fix...since Greg hasn't taken the series yet...I guess
I'll re-spin to include this fix. Probably wouldn't send it out until
tomorrow due to my test systems being down atm...

thanks,

-Jason


> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> index 9c8e133..122246f 100644
> --- a/lib/dynamic_debug.c
> +++ b/lib/dynamic_debug.c
> @@ -439,7 +439,9 @@ static char *dynamic_emit_prefix(const struct
> _ddebug *desc, char *buf)
> if (desc->flags & _DPRINTK_FLAGS_INCL_FUNCNAME)
> pos += snprintf(buf + pos, LEFT(pos), "%s:", desc->function);
> if (desc->flags & _DPRINTK_FLAGS_INCL_LINENO)
> - pos += snprintf(buf + pos, LEFT(pos), "%d ", desc->lineno);
> + pos += snprintf(buf + pos, LEFT(pos), "%d:", desc->lineno);
> + if (pos - strlen(KERN_DEBUG))
> + pos += snprintf(buf + pos, LEFT(pos), " ");
>
> return buf;
> }
> --
> 1.7.4.4
>
>
> also attached.
> If it doesnt apply, or you defer, I'll resend once Greg's accepted
> your whole set.

> From ec75cd50ba89bed1f0ad74b89c9a43e87b2bd767 Mon Sep 17 00:00:00 2001
> From: Jim Cromie <jim.cromie@xxxxxxxxx>
> Date: Tue, 2 Aug 2011 15:12:55 -0600
> Subject: [PATCH 03/28] dynamic_debug: add space at end of non-null
> dynamic-prefix
>
> dynamic_emit_prefix() currently adds a space after line-number,
> but not otherwize. For readability, add space whenever any prefix
> (besides the "<7>" loglevel) has been written.
>
> Signed-off-by: Jim Cromie <jim.cromie@xxxxxxxxx>
> ---
> lib/dynamic_debug.c | 4 +++-
> 1 files changed, 3 insertions(+), 1 deletions(-)
>
> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> index 9c8e133..122246f 100644
> --- a/lib/dynamic_debug.c
> +++ b/lib/dynamic_debug.c
> @@ -439,7 +439,9 @@ static char *dynamic_emit_prefix(const struct _ddebug *desc, char *buf)
> if (desc->flags & _DPRINTK_FLAGS_INCL_FUNCNAME)
> pos += snprintf(buf + pos, LEFT(pos), "%s:", desc->function);
> if (desc->flags & _DPRINTK_FLAGS_INCL_LINENO)
> - pos += snprintf(buf + pos, LEFT(pos), "%d ", desc->lineno);
> + pos += snprintf(buf + pos, LEFT(pos), "%d:", desc->lineno);
> + if (pos - strlen(KERN_DEBUG))
> + pos += snprintf(buf + pos, LEFT(pos), " ");
>
> return buf;
> }
> --
> 1.7.4.4
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/