Re: [PATCH 1/2] Add partition resize function to BLKPG ioctl

From: Joe Perches
Date: Mon Dec 12 2011 - 12:49:11 EST


On Mon, 2011-12-12 at 12:43 -0500, Phillip Susi wrote:
> On 12/12/2011 09:53 AM, Vivek Goyal wrote:
[]
> > - Can we rename BLKPG_RES_PARTITION to BLKPG_RESIZE_PARTITION. It is
> > easier to read.
> BLKPG_DELETE_PARTITION is also easier to read, but the existing code
> went with DEL. I prefer to stay consistent with the existing code and
> also use a 3 letter name.

RES is most commonly used for RESOURCE.

If it really needs to be 3 letters, and I don't think
it does, perhaps BLKPG_RSZ_PARTITION

> diff --git a/include/linux/blkpg.h b/include/linux/blkpg.h
> index faf8a45..103da38 100644
> --- a/include/linux/blkpg.h
> +++ b/include/linux/blkpg.h
> @@ -40,6 +40,7 @@ struct blkpg_ioctl_arg {
> /* The subfunctions (for the op field) */
> #define BLKPG_ADD_PARTITION 1
> #define BLKPG_DEL_PARTITION 2
> +#define BLKPG_RES_PARTITION 3


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/