Re: [RFC v2 1/7] hashtable: introduce a small and naive hashtable
From: Tejun Heo
Date: Fri Aug 03 2012 - 17:44:14 EST
Hello, Sasha.
On Fri, Aug 03, 2012 at 11:36:49PM +0200, Sasha Levin wrote:
> On 08/03/2012 11:30 PM, Tejun Heo wrote:
> The function definition itself is just a macro, for example:
>
> #define MM_SLOTS_HASH_CMP(mm_slot, obj) ((mm_slot)->mm == (obj))
It seems like it would make things more difficult to follow and
error-prone. I'd definitely prefer just using functions.
> As an alternative, what do you think about simplifying that to be
> just a 'cond' instead of a function? Something like:
>
> hash_get(&mm_slots_hash, mm, struct mm_slot, hash, mm);
>
> In that case, the last param ("mm") will get unrolled to a condition like this:
>
> if ((obj)->mm == key)
>
> Which will be simple and easy for the user.
It seems a bit too magical(tm) to me. ;)
> The only reason I want to keep this interface is that most cases
> I've stumbled so far were easy short comparisons of a struct member
> with the key, and I don't want to make them more complex than they
> need to be. I probably will switch hash_get() to use
> hash_for_each_possible() as well, which will cut down on how
> hash_get() is a separate case.
I can understand that but I think the benefit we're talking about is a
bit too miniscule to matter and to have two different interfaces.
What do others think?
Thanks.
--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/