On Fri, Oct 12, 2012 at 04:20:40PM +0530, Naveen N. Rao wrote:Hi Boris, Thanks for getting to this before I could!
Ah ok, I thought you wasn't interested in doing this anymore :).
I had a look but I still feel boolean is a better way to go. With
bool, we can get rid of the #defines above and more importantly, the
aux field in dev_ext_attribute since that is used in other places
too. Further, I suspect we'll still end up using the same or less
memory since we don't have that many boolean members within the MCA
code.
My main intention was to have all those in a single struct and use a
single store_bit/show_bit function.
Sure, you can do bools but this'll still be single variables spread
around in mce.c instead of one single struct mca_config which nicely
encapsulates all the configuration we do in the MCA code.
Or, you can modify the mca_config I have there and use bools and pass a
pointer to each actual bool member in each DEVICE_BIT_ATTR invocation
(and rename it to DEVICE_BOOL_ATTR). Yeah, that could work, unless I'm
missing something else, of course.