Re: [PATCH 2/2] rename NUMA fault handling functions
From: Ingo Molnar
Date: Fri Oct 19 2012 - 16:54:02 EST
* Rik van Riel <riel@xxxxxxxxxx> wrote:
> On 10/19/2012 07:41 AM, Peter Zijlstra wrote:
> >On Thu, 2012-10-18 at 17:20 -0400, Rik van Riel wrote:
> >>Having the function name indicate what the function is used
> >>for makes the code a little easier to read. Furthermore,
> >>the fault handling code largely consists of do_...._page
> > I don't much care either way, but I was thinking walken
> > might want to use something similar to do WSS estimation, in
> > which case the NUMA name is just as wrong.
> That's a good point. I had not considered other uses of the
> same code.
Renaming the functions for more clarity still makes sense IMO:
we could give it a _wss or _working_set prefix/postfix?
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/