Re: [PATCH 4/2] numa, mm: Rename the PROT_NONE fault handling functions

From: Rik van Riel
Date: Sun Oct 21 2012 - 09:25:13 EST

On 10/21/2012 08:50 AM, Ingo Molnar wrote:

* Ingo Molnar <mingo@xxxxxxxxxx> wrote:

I don't much care either way, but I was thinking walken
might want to use something similar to do WSS estimation,
in which case the NUMA name is just as wrong.

That's a good point. I had not considered other uses of the
same code.

Renaming the functions for more clarity still makes sense IMO:
we could give it a _wss or _working_set prefix/postfix?

So, to not drop your patch on the floor I've modified it as per
the patch below.

The _wss() names signal that these handlers are used for a
specific purpose, they are not related to the regular PROT_NONE
handling code.

Michel indicated that he does not use PROT_NONE for his
working set estimation code, but instead checks the
accessed bits in the page tables.

Since NUMA migration is the only user of PROT_NONE ptes
in normal vmas, maybe _numa is the right suffix after all?

All rights reversed
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at