tools/vm build fails

From: Daniel Hazelton
Date: Mon Oct 22 2012 - 20:00:53 EST

After doing any build in the kernel (last attempt was an allmodconfig) I've tried to build the 'vm' tool in tools/vm and the build fails - looks to be fallout from the uapi header work.

[madman@localhost tools]$ make V=1 vm
make -C vm/
make[1]: Entering directory `/home/madman/sources/linux-2.6/tools/vm'
gcc -Wall -Wextra -o page-types page-types.c
In file included from page-types.c:38:0:
../../include/linux/kernel-page-flags.h:4:42: fatal error: uapi/linux/kernel-page-flags.h: No such file or directory
compilation terminated.
make[1]: *** [page-types] Error 1
make[1]: Leaving directory `/home/madman/sources/linux-2.6/tools/vm'
make: *** [vm] Error 2

I'm not a kernel developer (I've tried and been unable to wrap my head around any part that I was going to try working on :( )and was just trying bits in tools/ at random to see what, exactly, they were and this kept happening, no matter the state of the tree.

I updated my git tree about 3 hours ago to mirror the latest Linus from after having run into this error yesterday and deciding I must have done something wrong. This looks like it might be a missing -I or similar since the file does exist and is at that exact path from the file that is directly including it.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at