On Thu, Mar 21, 2013 at 01:53:41PM -0400, Rik van Riel wrote:On 03/17/2013 11:11 AM, Mel Gorman wrote:On Sun, Mar 17, 2013 at 07:42:39AM -0700, Andi Kleen wrote:Mel Gorman <mgorman@xxxxxxx> writes:
@@ -495,6 +495,9 @@ typedef enum {
ZONE_CONGESTED, /* zone has many dirty pages backed by
* a congested BDI
*/
+ ZONE_DIRTY, /* reclaim scanning has recently found
+ * many dirty file pages
+ */
Needs a better name. ZONE_DIRTY_CONGESTED ?
That might be confusing. The underlying BDI is not necessarily
congested. I accept your point though and will try thinking of a better
name.
ZONE_LOTS_DIRTY ?
I had changed it to
ZONE_TAIL_LRU_DIRTY, /* reclaim scanning has recently found
* many dirty file pages at the tail
* of the LRU.
*/
Is that reasonable?